Pokaż wyniki 1 do 5 z 5

Temat: Metasploit - dodawanie exploitów

  1. #1
    Zarejestrowany
    Jul 2014
    Postów
    12

    Domyślnie Metasploit - dodawanie exploitów

    Hej!

    Dopiero zaczynam z Metaspliotem i mam mały, dość głupi problem, ale mam nadzieję, że pomożecie.
    Mianowicie nie mogę dodać exploitów pobranych np. z Exploit-DB. Robiłem wszystko według tego wideo, ale gdy już przychodzi do użycia nowego exploitu dostaję error: Failed to load module: exploit/samba/5712. Jak już łatwo się domyślić próbuję użyć komendy
    Kod:
    use exploit/samba/5712
    ,a plik z rozszerzeniem .pl, który pobrałem tutaj, wkleiłem do /.msf4/modules/exploits/samba.

    Z góry dzięki za pomoc!

  2. #2
    ocb
    ocb jest offline
    Zarejestrowany
    May 2011
    Postów
    392

    Domyślnie

    Cytat Napisał drakula103 Zobacz post
    Hej!

    Dopiero zaczynam z Metaspliotem i mam mały, dość głupi problem, ale mam nadzieję, że pomożecie.
    Mianowicie nie mogę dodać exploitów pobranych np. z Exploit-DB. Robiłem wszystko według tego wideo, ale gdy już przychodzi do użycia nowego exploitu dostaję error: Failed to load module: exploit/samba/5712. Jak już łatwo się domyślić próbuję użyć komendy
    Kod:
    use exploit/samba/5712
    ,a plik z rozszerzeniem .pl, który pobrałem tutaj, wkleiłem do /.msf4/modules/exploits/samba.

    Z góry dzięki za pomoc!
    Prawdopodobnie dlatego że metasploit wykorzystuje ruby, a ty wrzucasz mu splotia w perlu.

  3. #3
    Zarejestrowany
    Jul 2014
    Postów
    12

    Domyślnie

    Wydaje mi się, że z .rb też próbowałem i nic, ale jeszcze się upewnię.

  4. #4
    Zarejestrowany
    Jul 2014
    Postów
    12

    Domyślnie

    Skrypty .rb działają, ale co jak mam exploita, który nie jest napisany w Rubi (a takich jest cała masa)?

    Edit

    Już ogarnąłem, dzięki za pomoc
    Ostatnio edytowane przez drakula103 : 11-12-2014 - 17:00

  5. #5
    Zarejestrowany
    Mar 2015
    Postów
    2

    Domyślnie

    Cześć, jestem tutaj nowy i w przyszłości chciał bym pracować w bezpieczeństwie IT.
    Od kilku dni męczę się z dodaniem exploita do metasploita.

    Pobrałem tak jak tutaj i robiłem różnymi sposobami.
    probowałem z rozszerzeniem .pl oraz .rb pobrałem z Exploit-DB.
    I wyskakuje nadal mi błąd ...
    Pomożecie?

Zasady Postowania

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  
Subskrybuj