Strona 1 z 2 12 OstatniOstatni
Pokaż wyniki 1 do 10 z 11

Temat: Atak na neostradę liveboxa. Gdzie robimy błędy?

  1. #1
    Zarejestrowany
    Oct 2008
    Skąd
    Poznań
    Postów
    23

    Exclamation Atak na neostradę liveboxa. Gdzie robimy błędy?

    Chłopaki, potrzebuję waszej pomocy:
    1. Opisywany livebox jest celem wyłącznie edukacyjnym i nie służy do włamywania się do osób obcych
    2. Sytuacja jest bardzo dziwna, nie dziala internet, nie mogę pingować bramy

    - mam hasło WEP 128bit, mam autoryzowanego MAC klienta który jest b. rzadko aktywny. Nie ma więcej klientów
    - zasięg dobry, wszystko poustawiane, działam pod linuksem i windowsem
    - sieć nie przypisuje IP poprzez DHCP (wyłączony?)
    - sieć wygląda na domyślną: neostrada_XXX, hasło wygląda na wzięte z "pudełka livebox" podobniej jak: 34a6.{}
    - podaję hasło, na sztywno wpisuję poniżej dane = mam połączenie z routerem

    192.168.1.10 IP, próbowałem też X.X.1.2, X.X.1.3 działają wszystkie
    255.255.255.0
    192.168.1.1
    194.204.159.1
    194.204.152.34

    I teraz: nie działa ping i telnet 192.168.1.1, w sieci nie ma żadnych innych komputerów. Nie mogę połączyć z Internetem mimo połączenia z routerem. O co chodzi? Jakie następne kroki?
    Ostatnio edytowane przez rekruter : 10-21-2008 - 11:01

  2. #2
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    Jesli brama to 192.168.1.1 i nie odpowiada na ping to znaczy ze masz zla konfiguracje - to nie ta brama widac. Jesli wiesz ze adres MAC masz dobry i ze klient z tym adresem sie laczy do sieci i ze siec mu dziala... to podpatrz dokladnie jak ma ustawione IP bramy i jaka pula IP w ogole jest.

    Mam wrazenie ze uzywasz niewlasciwego przedzialu adresow... albo zlego adresu bramy. Od razu mowie - nie mam pojecia jak standardowo TP konfiguruje livebox'y wiec mnie o to nie pytaj :P
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

  3. #3
    Zarejestrowany
    Oct 2008
    Skąd
    Poznań
    Postów
    23

    Domyślnie

    Niestety jedyny klient którego MAC kiedyś złapałem pojawia się w tej sieci b. rzadko, raz na kilka dni stąd nie mam jak wyłapać jego ruchu i jakiegokolwiek ruchu w sieci. Nasłuch prowadzę dość długo i zaczynam się niecierpliwić, mimo połączenia z siecią i skanowania zakresu 192.168.1.XXX 192.168.2.XXX nic nie odbija pingów. Gdzie ta brama?

  4. #4
    Zarejestrowany
    Jun 2008
    Postów
    42

    Domyślnie

    Może przechodzą arp?Spróbuj posłuchać.Może wireshark.
    Router może nie dopuszczać do konfiguracji przez WLAN(domyślnie wyłączone).
    Jeżeli mac(spoofujesz),klucz wep,adres ip (taki sam) zweryfikowane,dhcp nie działa,brak internetu...
    Sprawdź dns,sprawdź czy po nazwie nie masz dostępu do routera (np ping nazwa).

    W sumie na liveboxach też się nie znam.
    Ostatnio edytowane przez wbart : 10-21-2008 - 13:27

  5. #5
    Zarejestrowany
    Oct 2008
    Skąd
    Poznań
    Postów
    23

    Domyślnie

    Zrzut sytuacji:



    Na zrzucie commview:
    W miejscu gdzie jest N/A to zapytania ARP
    w miejscu gdzie jest 192.168.1.255 to zapytania IP/UDP

    Jak pisałem wyżej:
    Internet - nie działa
    ping nazwa, dowolny ping 192.168.X.X - nie działa
    dhcp - nie działa
    klucz WEP - jak widać jest poprawny skoro połączony
    MAC - wysnifowany, poprawny, tylko on jest dopuszczony, inne nie działają. Na AP jestem sam
    zasięg - akurat w tym momencie słabszy bo niechcący przestawiłem antenę, ale normalnie jest lepszy

    Taką neostradę jest ciężko skonfigurować na inne maski bo trzeba użyć telnetowych komend TCL, ap najprwd. jest domyślnie skonfigurowany.
    Chłopaki, co teraz?
    Ostatnio edytowane przez rekruter : 10-21-2008 - 15:55

  6. #6
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    Nie wiem dlaczego ale mam wrazenie ze ten .1.2 to Twoj komp podlaczony na lewo... wysyla netbios na broadcast co jest normalne dla windows'a wiec to absolutnie NIC NIE MOWI ani o adresach IP ani o niczym innym. N/A przy pakietach z .1.2 do .1.1 oznacza ze .1.1 nie odpowiedzial - nie ma go tam gdzie go szukasz.

    Wysnifuj jak sie podlaczy klient i bedziesz mial wszystko na tacy podane. Po prostu uzywasz nie tego zakresu IP co powinienes

    Cytat Napisał wbart
    Sprawdź dns,sprawdź czy po nazwie nie masz dostępu do routera (np ping nazwa).
    Nooo ciekawe rozumowanie Jakim niby cudem ma dzialac DNS jak nie ma lacznosci z siecia? Gratuluje pomyslowosci
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

  7. #7
    Zarejestrowany
    Aug 2008
    Skąd
    Kraków
    Postów
    21

    Domyślnie

    Wychodzisz z błędnego założenia. Nie jesteś przyłączony do sieci. Wydaje Ci się, że jesteś. Przecież skonfigurowałeś ip, maskę, bramę na sztywno.

    DHCP na liveboxie można wyłączyć tylko z wiersza poleceń. Podobnie zmiana adresu bramy jest możliwa tylko poprzez wiersz poleceń. Można, więc odrzucić z góry, że jest to niepoprawny adres bramy.

    Zrób tak. Wyczyść adresy wpisane na sztywno. Zmień mac na mac klienta. Następnie spróbuj nawiązać połączenie z siecią. Jeśli pojawi się komunikat "sieć jest poza zasięgiem" to najpewniej błędny mac. Jeśli pojawi się komunikat z prośbą o wpisanie wep, a następnie przy sieci zamiast "połączono" - "automatycznie" to błędny wep.

  8. #8
    Zarejestrowany
    Jun 2007
    Postów
    59

    Domyślnie

    Mi sie udalo wymusic kiedys zeby sam mi przypisal brame , ip jest szansa ze moze sie udac.Jak juz wpisales klucz wep i podmieniles mac moze to smieszne ale sproboj uzyc opcji naprawTez mielem z tym problemy ja tak zrobilem i wyszlo
    Ostatnio edytowane przez hazi : 10-23-2008 - 18:27

  9. #9
    Zarejestrowany
    Oct 2008
    Skąd
    Poznań
    Postów
    23

    Exclamation

    1) Dzięki za sugestię chłopaki, wyjasniło się. Przyczyną jest zły klucz WEP, Wwaga: wzcook pod linuksa i windows i inne konwertery HEX/ASCII czasem podają złe przeliczenia kluczy haseł! aircrack łamie prawidło klucz ale konwertery kłamią! Dlatego nie przeliczajcie sobie haseł na ASCII tylko wrzucajcie HEX, zazwyczaj menadżery połączeń wifi powinny sobie poradzić.

    Jeśli aircrack-ng znalazł nam przykładowe hasło 128bit:
    KEY FOUND! [ 50:67:11:71:17:C6:EE:69:b9:31:39:50:13 ]
    wpisujemy hasło w ustawieniach sieci dokładnie w tym samym formacie bez znaczków ":" czyli hasło brzmi: 5067117117C6EE69b931395013
    Konwertery być może nie radzą sobie z nietypowymi znaczkami, w niektórych zamiast kropki w haśle był przecinek, w innym konwerterze podało to jako znak zapytania. Ale żadne translacje nie działały za wyjątkiem czystego HEX jak wyżej.

    2) Często menadżer połączeń robi nas w balona, na przykładzie WindowsXP: nie wyświetla informacji, że hasło WEP jest niepoprawne (mimo poprawnego wysnifowanego adresu MAC):

    Ustawienia naszej karty:
    a) Włączony DHCP, mamy wpisane złe hasło WEP/WPA. Zachowanie menadżera połaczeń:



    b) Wyłączamy DHCP i ręczne ustawienia, nadal mamy złe hasło WEP/WPA mimo rzekomego połączenia z siecią!, internetu oczywiście nadal nie ma, pingowanie bramy nic nie daje - nie istnieje:




    Rozwiązanie: Wystarczy wpisać dobry WEP/WPA i ustawić DHCP na wlasnej karcie aby sieć prawidłowo przypisała nam wszystkie potrzebne adresy i połączyła z Internetem neostrady skonfigurowanej domyślnie.
    Ostatnio edytowane przez rekruter : 10-25-2008 - 17:49

  10. #10
    Zarejestrowany
    Jul 2007
    Skąd
    UK
    Postów
    360

    Domyślnie

    aircrack poda Ci klucz i w hex i w ascii (o ile byl na ap wpisany w ascii, bo jesli byl w hex to przliczanie klucza na ascii prawdopodobnie wyrzuci jakis bzdetny wynik-musze sprobowac ), obojetnie jest, czy podasz klucz w hex czy w ascii, a ze klucz w hex wpisuje sie bez ":" czy "," to chyba oczywiste

    EDIT: http://www.mikezilla.com/exp0012.html
    Ostatnio edytowane przez bemyself : 10-26-2008 - 14:01
    Atheros? - nanzwa mhata yangu

Strona 1 z 2 12 OstatniOstatni

Podobne wątki

  1. Bardzo dziwne błędy
    By rafal44 in forum C/C++
    Odpowiedzi: 9
    Autor: 09-07-2008, 10:43
  2. Błędy na www - wykorzystanie/zabezpieczenie
    By Kapec in forum Newbie - dla początkujących!
    Odpowiedzi: 5
    Autor: 07-12-2008, 20:58
  3. hackowanie liveboxa
    By michalski007 in forum Hacking
    Odpowiedzi: 7
    Autor: 05-10-2007, 20:40

Zasady Postowania

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  
Subskrybuj