Pokaż wyniki 1 do 6 z 6

Temat: BT3 i Atheros 5418 (D-Link DWA-643 na expresscard)

  1. #1
    Zarejestrowany
    Sep 2008
    Postów
    3

    Domyślnie BT3 i Atheros 5418 (D-Link DWA-643 na expresscard)

    Z powodzeniem skompilowalem sterowniki madwifi, zainstalowalem, ale komenda

    modprobe ath_pci

    wcale nie startuje karty (przy czym zadnego komunikatu bledu nie ma)

    bt trunk # ifconfig
    eth0 Link encap:Ethernet HWaddr 00:1E:68:5A:7F:94
    inet addr:10.0.0.1 Bcast:10.0.0.255 Mask:255.255.255.0
    UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:56702 errors:0 dropped:0 overruns:0 frame:0
    TX packets:38365 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:81832307 (78.0 MiB) TX bytes:3310499 (3.1 MiB)
    Interrupt:18

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0) TX bytes:0 (0.0)

    bt trunk # iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wmaster0 no wireless extensions.

    wlan0 IEEE 802.11g ESSID:"" Nickname:""
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Tx-Power=27 dBm
    Retry min limit:7 RTS thrff Fragment thr=2346 B
    Encryption keyff
    Power Managementff
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    wlan0 to moja sieciowka Intel 4965ABG
    karta D-Link DWA-643 siedzi na expresscard

    Mam HP Pavilion z suwakiem uruchamiajacym wbudowana karte sieciowa Intel, gdzies kiedys trafilem na jakies info, ze ten suwak powinien byc przesuniety na ON/OFF, nie pamietam, moze Wy pamietacie.
    Czy to wogole moze powodowac problemy z instalacja drugiej karty na Atherosie?

    # lspsi | grep Network
    02:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
    04:00.0 Network controller: Atheros Communications, Inc. AR5418 802.11a/b/g/n Wireless PCI Express Adapter (rev ff)

    system widzi te karte na porcie ePci, ale plik /dev/ath0 nie istnieje.

    Probowalem sterownikow z ndiswrapper, ale tutaj takze bez rezultatu.
    Jak do tej pory nie udalo mi sie postawic ath0 device.

    Co jeszcze moge zrobic?

  2. #2
    Zarejestrowany
    Jul 2007
    Skąd
    UK
    Postów
    360

    Domyślnie

    hmmm napisz chociaz jaki masz os probowales na bt? Ja suwakow nie mialem w laptopie,ale minpci i pcimcia dzialaly obok siebie bez problemow, tyle ze obie atherosa:P ale to nie ma znaczenia chyba
    Ostatnio edytowane przez bemyself : 09-22-2008 - 21:23
    Atheros? - nanzwa mhata yangu

  3. #3
    Zarejestrowany
    Sep 2008
    Postów
    3

    Domyślnie

    System jest wskazany w tytule posta - Backtrack 3.
    Wersja madwifi - najnowsza z http://svn.madwifi.org/madwifi/trunk

  4. #4
    Zarejestrowany
    Aug 2008
    Skąd
    Kraków
    Postów
    21

    Domyślnie

    Piszesz, że użyłeś sterów madwifi trunk. Ale czy z tej daty ? (2008 08 01)

    madwifi.org:
    The following works on Apple's MacBook Pro (Core2 Duo T7700 2.4GHz): Linux kernel 2.6.24.7 w/ madwifi-trunk-r3832-20080801
    Ponadto znalazłem w internecie taki wpis odnośnie twojej karty:
    After some work, I successfully installed the card on Linux Mint 5, with the madwifi-trunk 02 Aug 2008 driver. I also installed aircrack-ng-1.0-rc for card testing purposes. The card did not work with madwifi-0.9.4 drivers. The kernel version I am running is 2.6.24-16-generic.
    Czyli muszą to być stery 1-2 sierpnia. Kolejna sprawa to jądro. W BT3 finalnym jest 2.6.21.5, a karta działa na pewno na 2.6.24.7 i późniejszych.

    Co do konfliktów z kartą intela w tym samym wpisie jest taka informacja:
    I have had intermittent problems with the card not being recognized, by Linux or Windows XP. After several reboots, the card has apparently started working again. The internal Intel wireless on my laptop does not play well with the new wireless card, so I must run one while the other is disabled or unplugged. The activity LED on the D-Link card does not blink under Linux, but does blink under Windows XP.

  5. #5
    Zarejestrowany
    Sep 2008
    Postów
    3

    Domyślnie

    Sprawdzilem madwifi z 01.08 i 02.08 - bez rezultatu, sprawdzalem na jadrze standardowym.

    Kompilacja jadra nie wchodzi w gre ze wzgledu na to, iz jest to live cd.
    Probowalem instalowac BT3 na USB pendrive, ale bez rezultatu pozytywnego wlasnie po to zeby zainstalowac najnowsze jadro gdzie te stery ath9k sa wbudowane (znalazlem wiele instrukcji w necie instalacji BT3 na USB, niestety w pewnym momencie dostaje kernel panic i nie moge tego ruszyc dalej). Kompilacja jadra nie wchodzi wiec w gre, ale nie sadze zeby to mialo cos do rzeczy skoro w jadrze moga byc co najwyzej sterowniki, ktore mam osobno.

    Przegrzebalem setki stron, znalazlem kilka przynajmniej instrukcji od A do Z instalacji tej karty, albo podobnych z tym samym chipsetem, ZADNA z nich nie zadzialala. Jak juz napisalem wczesniej stery ndiswrapper takze nie zadzialaly.

  6. #6
    Zarejestrowany
    Sep 2008
    Postów
    2

    Domyślnie

    Witam,
    Mam dokadnie ten sam problem Czy moze znane juz jest rozwiazanie tego problemu?

Podobne wątki

  1. BT3 i TP-Link TL-WN551G
    By D4r3K in forum Wardriving
    Odpowiedzi: 8
    Autor: 09-22-2008, 10:31
  2. bt3 final - d-link dwl-g520 rev.B
    By endriu1987 in forum Wardriving
    Odpowiedzi: 3
    Autor: 09-18-2008, 19:35
  3. atheros
    By kuki13 in forum Wardriving
    Odpowiedzi: 5
    Autor: 07-06-2008, 17:46
  4. Atheros AR5001X- drivery
    By gkrz in forum Wardriving
    Odpowiedzi: 3
    Autor: 03-30-2008, 12:34
  5. Sterowniki madwifi-ng Atheros
    By hazi in forum Wardriving
    Odpowiedzi: 19
    Autor: 03-20-2008, 20:24

Tagi

Zasady Postowania

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  
Subskrybuj