Pokaż wyniki 1 do 10 z 10

Temat: kanał monitora aircrack-ng

  1. #1
    Zarejestrowany
    Jan 2013
    Postów
    35

    Domyślnie kanał monitora aircrack-ng

    Jest to mój pierwszy post na forum więc- witam serdecznie wszystkich!
    Problem polega na tym, że aireplay-ng nie może wysłać pakietu odłączającego klienta od sieci :
    Kod:
    #aireplay-ng -0 4 -a FF:FF:FF:FF:FF:FF -c FF:FF:FF:FF:FF:FF mon0
    mon0 is on channel -1, but the AP uses channel 2
    Próbowałem także ustawić kanał przy starcie monitora:
    Kod:
    airmon-ng start wlan0 2
    ale otrzymuję identyczny komunikat.

    Kod:
    #lspci
    02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
    Pozdrawiam serdecznie
    //edit
    Wrzuciłem KALI Live i problem nie występuje, weird.Zastanawiam się czy problem nie leży po stronie :
    Kod:
    #airmon-ng check wlan0
    PID	Name
    1209	avahi-daemon
    1211	avahi-daemon
    1301	NetworkManager
    1363	wpa_supplicant
    1600	dhclient
    Process with PID 1600 (dhclient) is running on interface wlan0
    Ostatnio edytowane przez oziem : 09-10-2013 - 16:59

  2. #2
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    Moze chwila zastanowienia nad tym co robisz?
    Nie podam Ci gotowca, zastanow sie na komunikatami ktore widzisz - wszystko masz wyjasnione, tylko trzeba zrozumiec co kiedy dziala.
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

  3. #3
    Zarejestrowany
    Jan 2013
    Postów
    35

    Domyślnie

    Cytat Napisał TQM Zobacz post
    Moze chwila zastanowienia nad tym co robisz?
    Nie podam Ci gotowca, zastanow sie na komunikatami ktore widzisz - wszystko masz wyjasnione, tylko trzeba zrozumiec co kiedy dziala.
    hmm, może po kolei
    Kod:
    #airmon-ng start wlan0
    #airodump-ng mon0
    #airodump-ng --bssid FF:FF:FF:FF:FF:FF --channel 2 --write /root/pakiety mon0
    #aireplay-ng -0 4 -a FF:FF:FF:FF:FF:FF -c EE:EE:EE:EE:EE:EE mon0
    na dystrybucji LIVE działa bez zarzutu...

  4. #4
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    ok, to teraz jakie aplikacje uzywaja wlan0?
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

  5. #5
    Zarejestrowany
    Jan 2013
    Postów
    35

    Domyślnie

    Coś nie mogę dojść do tego.Próbowałem z wyłączonym avahi-daemon, wpa-supplicant, dhclientem i dalej nic.Później zobacze na LIVE jakie aplikacje tam chodzą.Pozdro

    //edit

    No i klapa.Generalnie jak opdalam airmon-ng start wlan0 z LIVE DVD to 2 procesy które chodzą na wlan0 to Network-manager i wpa_supplicant. Ciekawostką jest, że gdy odpalam airodump'a to w lewym górnym rogu okna mam "[CH]" i wartość tego zmienia się co chwilę.Natomiast na zainstalowanym systemie, oprócz tych dwóch aplikacji które wypisałem u góry, dochodzi jeszcze avahi-daemon i dhclient. Gdy zmieniłem adres IP połączenia bezprzewodowego na statyczny, proces dhclient zniknął.Zakończyłem też avahi-daemon.Teraz odpalam wszystko tak jak napisałem u góry i są tylko te 2 procesy, jak na LIVE.Następnie uruchamiam airodump'a i już widzę że wartość "[CH]" stoi w miejscu.Nie wiem dlaczego.
    Pozdrawiam.
    Ostatnio edytowane przez oziem : 09-13-2013 - 15:35

  6. #6
    Avatar Michal_sh
    Michal_sh jest offline (s)aint
    Zarejestrowany
    Apr 2007
    Postów
    688

    Domyślnie

    Podczas używania innych programów wyłącz airodump-ng

  7. #7
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    Pomysl logicznie, jaki jest wymog aby airmon-ng dzialal?
    Wszystko w nazwie w sume jest ukryte, do tego dodatkowe slady w postaci dzialajacych dhclient i network-manager... rozwiazanie az cisnie sie na usta.
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

  8. #8
    Zarejestrowany
    Nov 2006
    Skąd
    Polska/Poland
    Postów
    1,191

    Domyślnie

    Dali Ci latarkę, a Ty nadal w czarnej dupie...
    ***********
    * markossx *
    ***********

  9. #9
    Zarejestrowany
    Jan 2013
    Postów
    35

    Domyślnie

    No już się domyśliłem, że chodziło o mode monitor nie wiem jak mogłem wczesniej nie sprawdzić w jakim trybie ustawiona jest karta sieciowa.BTW. troszeczke mnie zmylił Kali live, bo tam nie trzeba było ustawiać karty w tryb monitor.Mimo wszystko dzięki wielkie
    Pozdrawiam

  10. #10
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    Gratujacle!

    Czasami jest tak ze nawet jak ustawiasz karte w tryb monitor to ona sie nie przelacza bo jakas aplikacja ja przyblokowala dla siebie wiec po zmianie warto sprawdzic czy na pewno jest monitor. Tak czy inaczej nic nie smakuje lepiej niz znalezienie rozwiazania samemu - teraz doskonale rozumiesz dlaczego nie dzialalo zamiast znac jedynie polecenia bez zrozumienia co robia i czemu sluza.
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

Zasady Postowania

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  
Subskrybuj