Pokaż wyniki 1 do 9 z 9

Temat: vpn. router -> mt.

  1. #1
    ocb
    ocb jest offline
    Zarejestrowany
    May 2011
    Postów
    392

    Domyślnie vpn. router -> mt.

    Witam. Mam problem z połączeniem vpn przez router bezprzewodowy którego wan jest w pięty do mt. Mt posiada całą konfigurację pppoe.
    Połączenie przez vpn działa bezpośrednio gdy wepnę kompa do lanu mt, jednak gdy chce połączyć się przez router połączenie stoi.
    Router skonfigurowany jest jako gateway z dhcp. Firewall jest wyłączony. Czego to może być kwestia?

    Można usunąć nie zauważyłem opcji w WAN enable PPTP
    Ostatnio edytowane przez ocb : 03-25-2012 - 12:50

  2. #2
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    Daj jakis diagram albo dwa (kiedy dziala a kiedy nie) bo opis niewiele wyjasnia.
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

  3. #3
    ocb
    ocb jest offline
    Zarejestrowany
    May 2011
    Postów
    392

    Domyślnie

    W zakładce WAN, dotyczącej WAN'u trzeba włączyć protokół PPTP(to zależy pewnie też od router'a, ale pewnie wygląda to podobnie na innych. Mój to black box jakiś). Myślałem że to wszystko wyjaśnia

  4. #4
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    Czyli masz Internet<->MT<->router wifi<->Twoj komp... i na kompie chcesz odpalic PPTP i to dziala jak podepniesz sie do MT ale nie jak podepniesz sie do wifi...

    Proste - napisales ze router wifi ma wylaczony firewall... a to znaczy ze nie robi NAT i pakiety prawdopodobnie w ogole nie docieraja do MT. "Pass-Through" z tego co mi wiadomo dziala TYLKO jesli masz podniesiony firewall, bo firewall wlasnie musi dokonac zmian w pakeitach. Proponowalbym zastapic router zwyklym AP albo dodac do MT karte aby dzialal jako router wifi (dodac karte wifi jako kolejny interfejs LAN) - jesli to sprzet Twojego ISP to pogadaj z nim - zajmie to doslownie pare minut najprawdopodobniej i bedzie po problemie.
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

  5. #5
    ocb
    ocb jest offline
    Zarejestrowany
    May 2011
    Postów
    392

    Domyślnie

    ogólnie rzecz biorąc to jest po problemie nie działał mi tylko vpn. To jest sprzęt z pracy (rb411) i akurat innego routerboard'a nie mogę pożyczyć NAT ustawiłem na mt.

  6. #6
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    No tak, 411 to CPE - jedna karta wifi i koniec tematu...

    To zrob inaczej... skonfiguruj klienta PPTP na MT i normalnie NATuj na MT te maszyny co maja miec dostep do VPNu :-) PPTP bedzie sie zachowywac jak gateway do innej sieci i dodajac zapisy w tabeli routingu, bedziesz mial co trzeba - przyajmniej tak cos pamietam.

    Klienta ustawiasz w Interfaces->Add->PPTP Client ale nie dajesz 'Add default route' tylko dalej recznie ustawiasz routing i NAT na MT. Teraz jesli masz dobrze ustawiony NAT to nawet na tym routerze wifi zadziala bo PPTP bedzie szlo z MT maszyny w LAN w ogole nie beda swiadome jakiegokolwiek VPNa.
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

  7. #7
    ocb
    ocb jest offline
    Zarejestrowany
    May 2011
    Postów
    392

    Domyślnie

    Z tego co koledzy mi podpowiedzieli to jest to kwestia tego blackbox'a gdyż inne router'y np tplink'a puszczają wszystko normalnie. Twoje rozwiązanie chodź wydaję mi się skomplikowane(pod względem moich umiejętności) i tak nie spełni się w moim przypadku ponieważ jeśli dobrze zrozumiałem to mt będzie ciągle trzymał połączenie vpn, a mi tylko zależy na tym 'z doskoku'.

  8. #8
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    Winbox->Interfaces->PPTP Client->Enable :-)
    ... a jak nie potrzebujesz to Disable i po sprawie :-D
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

  9. #9
    ocb
    ocb jest offline
    Zarejestrowany
    May 2011
    Postów
    392

    Domyślnie

    Cytat Napisał TQM Zobacz post
    Winbox->Interfaces->PPTP Client->Enable :-)
    ... a jak nie potrzebujesz to Disable i po sprawie :-D
    i za każdym razem logować się na urządzenie

Zasady Postowania

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  
Subskrybuj