Pokaż wyniki 1 do 3 z 3

Temat: openssl

  1. #1
    Zarejestrowany
    Nov 2006
    Skąd
    Polska/Poland
    Postów
    1,191

    Question openssl

    napaskudziłem sobie i nie wiem co zrobić za bardzo, otóż:
    - miałem na serwerku openssl w wersji 0.9.7a
    - mówię zaktualizuje do wersji 0.9.8e, żeby było ładnie
    - skompilowałem, zainstalowałem
    - okazało się, że stara wersja siedzi w openssl: /usr/bin/openssl i
    /usr/include/openssl
    a nowa zainstalowała się: /usr/local/ssl/
    czyli mam dwie wersje openssl'a ale jak wpisze w powłoce openssl to system widzi starą wersję
    jeśli chce urzyć nowszej muszę podać całą ściechę czyli:
    /usr/local/ssl/bin/openssl
    zresztą potrzebuje tego do jednej rzeczy, która i tak widzi tylko starą wersję..

    mogę gdzieś zmienić w zmiennych systemowych żeby mi łykał nową wersję (?)
    czy jak zainstaluję jeszcze raz i dam odpowiednie ściechy w ./configu..?
    to będzie dobrze..? nie spowoduje to jakiejś rozwałki..?
    chciałem wywalić starego ssl'a ale drze japę, że zależności!!!
    macie jakieś pomysły..?

    pzdr.
    ***********
    * markossx *
    ***********

  2. #2
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    ./configure --prefix=....

    Mozesz tez na pale podlinkowac katalogi :-) to rozwiazanie niezbyt zalecane ale dziala! Zmien nazwy katalogow np:

    ### binarka
    mv /usr/bin/openssl /usr/bin/openssl-old
    ln -s /usr/local/ssl/bin/openssl /usr/bin/openssl

    podobnie pliki naglowkowe - cale katalogi mozna tak podmieniac... no i zawsze masz stara wersje Generalnie jesli uzywasz jakiegos systemu pakietow (.deb, .rpm, itd) to polcam zostac przy pakietach... Jesli juz musisz recznie kompilowac to mozesz albo zmienic to recznie (j.w.) albo sprobowac wczesniej odinstalowac oryginalny pakiet ale licz sie z tym ze mozesz zerwac zaleznosci - co nie jest dobre.

    Generalnie sporo aplikacji ma 'make uninstall' :-) i ladnie sprzata po sobie... nie wiem jednak czy openssl tak ma - mozesz sprawdzic.

  3. #3
    Zarejestrowany
    Nov 2006
    Skąd
    Polska/Poland
    Postów
    1,191

    Lightbulb



    robiłem akurat w week kopie systemu plików i się trochę tym pobawiłem;
    podlinkowanie działało dobrze ale chciałem sprawdzić drugą opcję:
    ztarowałem katalogi gdzie przebywała stara wersja i następnie je oczyściłem ze wszystkich, łącznie z bibliotekami nagłówkowymi (chociaż większość była identyczna);
    za pomocą ./configure dałem odpowiednie ścieżki, skompilowałem, zainstalowałem i jest ok
    zresztą znalazłem info, że openssl od którejś wersji instaluje sie w innym miejscu i żeby uważać żeby się dwóch wersji nie miało - ale starym zwyczajem człowiek najpierw próbuje sam a potem czyta manuala...

    dzięki tqm
    ***********
    * markossx *
    ***********

Zasady Postowania

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  
Subskrybuj

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52