Strona 1 z 2 12 OstatniOstatni
Pokaż wyniki 1 do 10 z 17

Temat: Połączenie internetowe

  1. #1
    Zarejestrowany
    May 2007
    Skąd
    C:\Documents and Settings\micro
    Postów
    39

    Domyślnie Połączenie internetowe

    Mam pewien problem, niedawno zainstalowałem sobie linuxa i ... nie mogę się w żaden sposób podłączyć do internetu. Mam sieć Lan z dwoma komputerami, łączę się przez router a internet biore z neostrady netia, na windowsie wszystko działa ale na linuxie już nie bardzo.

    Robie wszystko jak jest w pomocy, czyli przechodze przesz System/administation/networking i widać moje połącznie wired connection address dhcp. Pokazuje się chmurka Connection Established You are now connected to the wired network.

    Ale jak otwieram przeglądarkę to nie może wczytać żadnej strony, nawet jak chcę wejśc do panelu administracyjnego sieci i wpisuje 10.0.0.2 to nie chce wyświetlić. To znaczy że ten router jest niekompatybilny z linuxem czy coś takiego? Bo jak windowsie nie było połączenia to do panelu mozna było wejść.

    W pomocy nic nie ma napisane o tym jak się łączyć w przypadku sieci lan, szukałem oczywiśćie w internecie ale nic co by odpowiadało mojemu problemowi nie znalazłem. Jeszcze jak się łączyłem przez modem to koleś z netii powiedział że muszę ściągnąć sterowniki pod linuxa, ale jak się teraz łącze przez router to już chyba nie powinienem, prawda?
    Z góry dzięki.
    "There is no spoon"

  2. #2
    Zarejestrowany
    Jun 2006
    Postów
    141

    Domyślnie

    Pokaz wynik polecenia ifconfig
    Co to za distro?

  3. #3
    Zarejestrowany
    May 2007
    Skąd
    C:\Documents and Settings\micro
    Postów
    39

    Domyślnie

    Ubuntu 7.04

    ifconfig
    eth0 Link encap:Ethernet HWaddr 00:1A:92:38:340
    inet6 addr: fe80::21a:92ff:fe38:34d0/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:100 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:28333 (27.6 KiB)
    Interrupt:17 Base address:0x6000

    eth0:avah Link encap:Ethernet HWaddr 00:1A:92:38:340
    inet addr:169.254.6.199 Bcast:169.254.255.255 Mask:255.255.0.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    Interrupt:17 Base address:0x6000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:850 errors:0 dropped:0 overruns:0 frame:0
    TX packets:850 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:70076 (68.4 KiB) TX bytes:70076 (68.4 KiB)
    "There is no spoon"

  4. #4
    Zarejestrowany
    Jun 2006
    Skąd
    Polska, zachodniopomorskie
    Postów
    46

    Domyślnie

    Jeżeli ruter podaje IP po dhcp należy wydać komendę:

    dhcp

    ew. odmianę, czyli:

    dhcpd
    dhcpcd

    To powinno wystarczyć samo w sobie, jeżeli ruter podaje dns, gateway, Ip i maskę sieci.

    Jeżeli ruter nie podaje nic po dhcp to skonfigurować interfejs, np.

    ifconfig eth0 192.168.0.10 netmask 255.255.255.0

    lub

    ifconfig eth0 10.0.0.10 netmask 255.255.255.0

    W /etc/resolv.conf powinieneś mieć dyrektywy typu:

    nameserver <IP_serwera_dns>

    Ja nie wiem jakie to IP, nie pytaj mnie ale powinieneś mieć na jakiejś broszurce a właściwie umowie od Netii. Przykładowy wpis w /etc/resolv.conf

    nameserver 194.204.159.1

    Starczy jeden, dla pewności dobre są dwa - jak jeden serwer nazw padnie to komputer zacznie pytać drugiego.

    Jeżeli zabraknie rutingu to możesz też mu podać z palca:

    route add default gw <adres_IP_routera>

    sprawdzić iptables (czasami distro dodaje od siebie kilka niepotrzebnych rzeczy):

    iptables -L INPUT
    iptables -L FORWARD
    iptables -L OUTPUT
    iptables -t nat -L PREROUTING
    iptables -t nat -L OUTPUT
    iptables -t nat -L POSTROUTING
    iptables -t mangle -L PREROUTING
    iptables -t mangle -L OUTPUT

    Jeżeli coś tam będzie to można pomyśleć o wyczyszczeniu czyli

    iptables -F INPUT
    iptables -F FORWARD
    iptables -F OUTPUT
    iptables -t nat -F PREROUTING
    iptables -t nat -F OUTPUT
    iptables -t nat -F POSTROUTING
    iptables -t mangle -F PREROUTING
    iptables -t mangle -F OTUPUT

    I jeszcze można wyczyścić ew. łańcuchy dodatakowe:

    iptables -X INPUT
    iptables -X FORWARD
    iptables -X OUTPUT
    iptables -t nat -X PREROUTING
    iptables -t nat -X OUTPUT
    iptables -t nat -X POSTROUTING
    iptables -t mangle -X PREROUTING
    iptables -t mangle -X OTUPUT

    Uhhh, ile pierdolenia z tym. Powodzonka ;-)


    Żeby nie rozwinąć tematu za daleko a później go nie skonczyć to zaraz jak już dojdziesz co i jak masz zrobić żeby działało to daj wszystkie komendy do pliku któy wypisze Ci polecenie:

    find /etc/ -name *local* -type f 2>/dev/null

    Jak ktoś mu może podać lokalny skrypt na Ubuntu to podajcie bo ja już nie pamiętam.

    Pozdrawiam,
    I_v0

  5. #5
    Zarejestrowany
    Jun 2006
    Postów
    141

    Domyślnie

    Jezeli to ubuntu to pewnie tak samo jest jak w debianie

    Z tego co widze to DHCP lapie zle ip.. Bo sadze ze albo masz siec z 192.168.0.* albo 10.0.0.*

    Sprawdz jaki masz wpis w /etc/network/interfaces

    Moj wyglada tak:
    auto lo
    iface lo inet loopback

    # The primary network interface
    allow-hotplug eth0
    iface eth0 inet static
    address 192.168.0.11
    netmask 255.255.255.0
    gateway 192.168.0.1
    Dla DHCP powinno wygladac tak:
    iface eth0 inet dhcp

  6. #6
    Zarejestrowany
    Nov 2006
    Skąd
    Polska/Poland
    Postów
    1,191

    Domyślnie

    młodszy-jeśli to ubuntu to nie koniecznie musi być jak w debku
    prawie czyni różnice......
    ***********
    * markossx *
    ***********

  7. #7
    Zarejestrowany
    May 2007
    Skąd
    C:\Documents and Settings\micro
    Postów
    39

    Domyślnie

    Sprawdz jaki masz wpis w /etc/network/interfaces
    auto lo
    iface lo inet loopback

    auto eth1
    iface eth1 inet dhcp

    auto eth2
    iface eth2 inet dhcp

    auto ath0
    iface ath0 inet dhcp

    auto wlan0
    iface wlan0 inet dhcp
    Jeżeli ruter podaje IP po dhcp należy wydać komendę:

    dhcp

    ew. odmianę, czyli:

    dhcpd
    dhcpcd

    To powinno wystarczyć samo w sobie, jeżeli ruter podaje dns, gateway, Ip i maskę sieci.

    Jeżeli ruter nie podaje nic po dhcp to skonfigurować interfejs, np.

    ifconfig eth0 192.168.0.10 netmask 255.255.255.0

    lub

    ifconfig eth0 10.0.0.10 netmask 255.255.255.0
    [email protected]:~$ dhcp
    bash: dhcp: command not found
    [email protected]:~$ dhcpd
    The program 'dhcpd' is currently not installed. You can install it by typing:
    sudo apt-get install dhcp
    Make sure you have the 'universe' component enabled
    bash: dhcpd: command not found
    [email protected]:~$ sudo apt-get install dhcp
    Czytanie list pakietów... Gotowe
    Budowanie drzewa zależności
    Reading state information... Gotowe
    E: Nie udało się odnaleźć pakietu dhcp
    [email protected]:~$ dhcpcd
    The program 'dhcpcd' is currently not installed. You can install it by typing:
    [email protected]:~$ sudo apt-get install dhcpcd
    Czytanie list pakietów... Gotowe
    Budowanie drzewa zależności
    Reading state information... Gotowe
    E: Nie udało się odnaleźć pakietu dhcpcd
    [email protected]:~$ ifconfig eth0 192.168.0.10 netmask 255.255.255.0
    SIOCSIFADDR: Permission denied
    SIOCSIFFLAGS: Permission denied
    SIOCSIFNETMASK: Permission denied
    [email protected]:~$ ifconfig eth0 10.0.0.10 netmask 255.255.255.0
    SIOCSIFADDR: Permission denied
    SIOCSIFFLAGS: Permission denied
    SIOCSIFNETMASK: Permission denied

    W /etc/resolv.conf powinieneś mieć dyrektywy typu:

    nameserver <IP_serwera_dns>
    Ja tu mam tylko folder update-libc.d , gdzie powinny byc te dyrektywy

    sprawdzić iptables (czasami distro dodaje od siebie kilka niepotrzebnych rzeczy):

    iptables -L INPUT
    iptables -L FORWARD
    iptables -L OUTPUT
    iptables -t nat -L PREROUTING
    iptables -t nat -L OUTPUT
    iptables -t nat -L POSTROUTING
    iptables -t mangle -L PREROUTING
    iptables -t mangle -L OUTPUT

    Jeżeli coś tam będzie to można pomyśleć o wyczyszczeniu czyli

    iptables -F INPUT
    iptables -F FORWARD
    iptables -F OUTPUT
    iptables -t nat -F PREROUTING
    iptables -t nat -F OUTPUT
    iptables -t nat -F POSTROUTING
    iptables -t mangle -F PREROUTING
    iptables -t mangle -F OTUPUT

    I jeszcze można wyczyścić ew. łańcuchy dodatakowe:

    iptables -X INPUT
    iptables -X FORWARD
    iptables -X OUTPUT
    iptables -t nat -X PREROUTING
    iptables -t nat -X OUTPUT
    iptables -t nat -X POSTROUTING
    iptables -t mangle -X PREROUTING
    iptables -t mangle -X OTUPUT
    za każdym razem jest error
    "There is no spoon"

  8. #8
    Zarejestrowany
    Jun 2006
    Skąd
    Polska, zachodniopomorskie
    Postów
    46

    Domyślnie

    O stary, co to za distro?! Porazka panie, nie zanam distro to nie bede mieszal - to co Ci dalem na wielu odmianach Linuxa by zadzialalo moze nie Ubuntu po prostu
    Ostatnio edytowane przez I_v0 : 07-04-2007 - 20:48 Powód: Troche sie zestresowalem instalacja Vmware

  9. #9
    Zarejestrowany
    Jun 2006
    Postów
    141

    Domyślnie

    [email protected]:~$ dhcp
    bash: dhcp: command not found
    [email protected]:~$ dhcpd
    The program 'dhcpd' is currently not installed. You can install it by typing:
    sudo apt-get install dhcp
    Make sure you have the 'universe' component enabled
    bash: dhcpd: command not found
    [email protected]:~$ sudo apt-get install dhcp
    Czytanie list pakietów... Gotowe
    Budowanie drzewa zależności
    Reading state information... Gotowe
    E: Nie udało się odnaleźć pakietu dhcp
    [email protected]:~$ dhcpcd
    The program 'dhcpcd' is currently not installed. You can install it by typing:
    [email protected]:~$ sudo apt-get install dhcpcd
    Czytanie list pakietów... Gotowe
    Budowanie drzewa zależności
    Reading state information... Gotowe
    E: Nie udało się odnaleźć pakietu dhcpcd
    To wszystko mowi Brak Ci DHCP dlatego tez masz do wyboru ... Albo statyczne ip albo robisz DHCP.

    Jezeli statyczne to tak jak u mnie robisz.. Tylko co najwyzej zmieniasz parametry aby pasowaly do Twojego routera...

    No a teraz DHCP
    Najpierw zwieksz zakres repozytoriow. Tutaj ladnie napisane co trzeba zrobic:
    http://forum.ubuntu.pl/viewtopic.php?t=1591
    Pierwszy post dotyczy wlasnie Twojej wersji.

    A teraz zamiast uzywac apt-get uzyj aptitude. Dla mnie jest lepsze rozwiazanie od apta.

    Tutaj ladnie opisane: http://www.psychocats.net/ubuntu/aptitude

    No i albo robisz tak jak tam podane czyli:
    sudo aptitude update
    sudo aptitude install dhcp
    Albo po prostu:
    sudo aptitde
    Po tym poleceniu uruchomi Ci sie w konsoli aplikacja aptitude. Powinno byc raczej po polsku. Robisz update wtedy repozytoriow i wyszukujesz frazy dhcp.. Na dole beda opisy. Z tego co pamietam to Ci trzeba "dhclient" ale nie zaszkodzi troszke od DHPC zainstalowac.. Tylko pomin "dhcp serwer".

  10. #10
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    Ja pierdziele... a moze by tak dhcpcd uruchomic jako root, co?
    Jako user to se mozesz w kabel dmuchac i nic sie nie stanie....
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

Strona 1 z 2 12 OstatniOstatni

Podobne wątki

  1. Kamery internetowe w google.pl !
    By Kamlo in forum Google hacks
    Odpowiedzi: 23
    Autor: 10-10-2018, 01:02
  2. Odpowiedzi: 15
    Autor: 12-19-2007, 12:08
  3. typy atakow na strony internetowe
    By marcio in forum Hacking
    Odpowiedzi: 0
    Autor: 06-23-2007, 22:04

Zasady Postowania

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  
Subskrybuj