Pokaż wyniki 1 do 4 z 4

Temat: Nagios nie moitoruje serwisów - komputery/serwery Windows

  1. #1
    Zarejestrowany
    Aug 2012
    Postów
    2

    Domyślnie Nagios nie moitoruje serwisów - komputery/serwery Windows

    Witam,

    Zainstalowałem Nagios i mam problem z minitoringiem hostów z Windows 7.
    Maszyny pracują w sieci lokalnej, jeden serwer znajduje się za Natem.

    Na komputerach z Windows 7 i serwerze zainstalowałem agenta NSClient++ (konkretnie: NSCP-0.4.0.183-x64.msi ), ale niestety nie jestem w stanie monitorować na przykład pojemności twardego dysku itp.

    Przykładowo:
    Service: C:\ Drive Space
    Status: WARNING
    Status Information: could not fetch information from server

    Natomiast:
    Service: Memory Usage
    Status: CRITICAL
    Status Information: (Return code of 139 is out of bounds)

    Ale już np.

    Service: NSClient++ Version
    Status: OK
    Status Information: (No output returned from plugin)

    Bardzo proszę o pomoc. Załączam moje pliki konfiguracyjne i zrzut ekranu z widokiem maszyn z Nagiosa.

    Serwer dla Nagiosa postawiłem na Debianie 6.0.5 zainstalowałem X i TeamVewera chętnie dam dostęp.

    Prawdopodobnie nie mam odpowiednich pluginów, ale nie wiem czy powinienem je wgrać po stronie Windows czy Linuxa z Nagiosem?

    Pozdrawiam i zgóry bardzo dziękuję za pomoc.
    Olek
    Załączone Pliki Załączone Pliki
    Ostatnio edytowane przez olekstar : 08-10-2012 - 16:52

  2. #2
    Zarejestrowany
    Nov 2006
    Skąd
    Polska/Poland
    Postów
    1,191

    Domyślnie

    Może samego agenta należy uruchamiać jako administrator?
    ***********
    * markossx *
    ***********

  3. #3
    Zarejestrowany
    Aug 2012
    Postów
    2

    Domyślnie

    Witam,

    Bardzo dziękuję markossx, teraz działa

    Co prawda nie wiem dlaczego, ale na Windowsach pokazuje się, że Explorer.exe: not running

    Pozdrawiam
    olekstar

  4. #4
    Zarejestrowany
    Nov 2006
    Skąd
    Polska/Poland
    Postów
    1,191

    Domyślnie

    Być może nawet ten administrator nie ma dostępu do procesu explorer.exe, nie powiem Ci dokładnie bo staram się omijać "7". Poszukaj nieco.
    ***********
    * markossx *
    ***********

Tagi

Zasady Postowania

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  
Subskrybuj