Pokaż wyniki 1 do 2 z 2

Temat: Problemy z kodowaniem znaków

  1. #1
    Zarejestrowany
    Aug 2014
    Postów
    1

    Domyślnie Problemy z kodowaniem znaków

    Witajcie,
    Założyłem konto na tym portalu bo mam problem, którego od jakiegoś czasu nie potrafię rozwiązać. Napisałem skrypt, który wysyła maile po pojawieniu się wpisu w bazie MySQL. Problem polega na tym, że w mailu nie ma polskich liter tylko są krzaki.
    W skypcie wykorzystuję
    Kod:
    use utf8
    a do wysyłania maila
    Kod:
    MIME::Lite
    . Próbowałem wysyłać maile jako HTML i plain text ale to nie pomagało.
    Dziwne jest to, że tytuł maila pobieram z bazy i ten Tytuł wyświetla się z krzakami zamiast polskich liter a później w mailu wyświetlanie jest poprawne. W bazie metoda powrównywanie napisów to utf8_polish_ci.
    Macie jakiś pomysł jak to naprawić?

    Pozdrawiam,
    Maciek

  2. #2
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    Ustawic odpowiednie kodowanie trzeba i tyle... maile maja naglowek do tego - poszukaj w dokumentacji bo nie pamietam jak to szlo. Jak wysylasz mail w HTML to w HTMLu mozesz w META podac jakie jest kodowanie i tyle, wyslac HTML jako zalacznik typu INLINE i wyswietli sie jako tresc maila.
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

Zasady Postowania

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  
Subskrybuj

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52