Pokaż wyniki 1 do 1 z 1

Temat: Hydra problemy przy instalacji. Pytania/odpowiedzi

  1. #1
    Zarejestrowany
    Dec 2006
    Postów
    24

    Domyślnie Hydra problemy przy instalacji. Pytania/odpowiedzi

    Hej Niedawno sam miałem dużo problemów z tym ptogramem ale sobie poradziłem dlatego postanowiłem opisać wszyskie problemy i sopozoby rozwiązań.

    ( wszyskie pliki również do pobrańsia z http://serwis.comli.com/ )
    Pobieramy hydre z:
    http://freeworld.thc.org/releases/hydra-5.4-src.tar.gz
    Rozpakowywujemy paczke i zaczynamy zabawe!
    ./configure - umożliwi nam konfiguracje hydy i pokaże czy aby napewno mamy wszyskie pakiety potrzebne.
    Kod:
    [email protected]:~/Pulpit/hydra$ ./configure
    
    Starting hydra auto configuration ...
    
    Checking for openssl (libssl/ssl.h) ...
                                        ... found
    Checking for Postgres (libpq) ...
                                  ... found
    Checking for SVN (ibsvn_client-1 libapr-0.so libaprutil-0.so) ...
                                  ... found
    Checking for SAP/R3 (librfc/saprfc.h) ...
                                          ... NOT found, module sapr3 disabled
    Get it from http://www.sap.com/solutions/netweaver/linux/eval/index.asp
    Checking for libssh (libssh/libssh.h) ...
                                          ... found
    NOTE: ensure that you have libssh v0.11 installed!! Get it from http://0xbadc0de.be !
    
    Hydra will be installed into .../bin of: /usr/local
      (change this by running ./configure --prefix=path)
    
    Writing Makefile.in ...
    
    NOTES NOTES NOTES NOTES NOTES NOTES NOTES NOTES NOTES NOTES NOTES NOTES
    =======================================================================
    ARM/PalmPilot users: please run ./configure-arm or ./configure-palm respectivly
    Bardzo waże jest posiadanie wszystkich paczek:
    Kod:
    openssl 
    Postgres
    SVN
    SAP/R3 - Tej nie umialem znaleść ale słyszałem że można ją olać :)
    libssh v0.11 - bardzo ważne żeby mieć w wersji 0.11
    Mając wszysko przechodzimy do:
    sudo make
    Poprawnie wygląda tak:
    Kod:
    [sudo] password for marek: 
    
    Now type make install
    [email protected]:~/Pulpit/hydra$
    Ale i tu można napotkać problem który może wyglądać tak:
    Kod:
    [email protected]:~/Pulpit/hydra$ sudo make
    cd hydra-gtk && ./make_xhydra.sh
    Trying to compile xhydra now (hydra gtk gui) - dont worry if this fails, this is really optional ...
    Error: could not compile. Analyse this:
    callbacks.c: In function ?popen_re_unbuffered?:
    callbacks.c:532: warning: format not a string literal and no format arguments
    callbacks.c: In function ?on_btnSave_clicked?:
    callbacks.c:668: warning: ignoring return value of ?write?, declared with attribute warn_unused_result
    In file included from /usr/include/fcntl.h:217,
                     from callbacks.c:27:
    In function ?open?,
        inlined from ?on_btnSave_clicked? at callbacks.c:666:
    /usr/include/bits/fcntl2.h:51: error: call to ?__open_missing_mode? declared with attribute error: open with O_CREAT in second argument needs 3 arguments
    In file included from /usr/include/stdio.h:910,
                     from /usr/include/pango-1.0/pango/pango-utils.h:25,
                     from /usr/include/pango-1.0/pango/pango.h:46,
                     from /usr/include/gtk-2.0/gdk/gdktypes.h:37,
                     from /usr/include/gtk-2.0/gdk/gdkscreen.h:32,
                     from /usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:31,
                     from /usr/include/gtk-2.0/gdk/gdk.h:32,
                     from /usr/include/gtk-2.0/gtk/gtk.h:32,
                     from callbacks.c:11:
    In function ?snprintf?,
        inlined from ?hydra_get_options? at callbacks.c:247:
    /usr/include/bits/stdio2.h:65: warning: call to __builtin___snprintf_chk will always overflow destination buffer
    make[3]: *** [callbacks.o] Błąd 1
    make[2]: *** [all-recursive] Błąd 1
    make[1]: *** [all-recursive-am] Błąd 2
    
    Do not worry, as I said, xhydra is really optional. ./hydra is ready to go!
    Rozwiązanie jest bardzo banalne należy weść w:
    hydra-gtk/src/callbacks.c - otwórz przy pomocy edytora tekstowego i znajdz:
    Kod:
    fd = open(filename, O_CREAT | O_TRUNC | O_WRONLY);
    i zamień na:
    Kod:
    fd = open(filename, O_CREAT | O_TRUNC | O_WRONLY, 0666);
    I teraz pozostaje już tylko:
    sudo make install
    I wszysko hula!

    Sposób dla leniwych:
    Kod:
    http://www.freshnet.org/debian/dapper/hydra/
    Pobieramy hyder w pacze .deb
    Jeżeli wyskakuje nam czerwony napisze:
    Kod:
    libssl0.9.7
    To pobieramy paczke z :
    Kod:
    http://packages.debian.org/etch/i386/libssl0.9.7/download
    A tu 2 kolejne linki do paczek które też są potrzebne:
    Kod:
    http://packages.debian.org/etch/i386/libpq4/download
    Kod:
    http://packages.debian.org/etch/i386/libkrb53/download
    I teraz spokojenie możemy instalować Hydre.

    Mam nadzieje że się komuś to przyda.
    Ostatnio edytowane przez GarF : 03-19-2010 - 22:32

Zasady Postowania

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  
Subskrybuj