Strona 1 z 2 12 OstatniOstatni
Pokaż wyniki 1 do 10 z 12

Temat: swap?

  1. #1
    Zarejestrowany
    Aug 2009
    Postów
    408

    Domyślnie swap?

    wszystko jest plikiem
    takie cos kiedys przeczytalem i tak rozumielem linuxa.
    zawsze mialem plik /swap
    teraz go niema
    Kod:
    Linux a-desktop 2.6.28-15-generic #52-Ubuntu SMP Wed Sep 9 10:48:52 UTC 2009 x86_64 GNU/Linux
    ale swap dziala (albo mi sie zdaje ze dziala).
    mam 2 partycje, /dev/sda1 i /dev/sda2.
    1 ma 78 giga, 2 ma 2 giga

    wiecie moze jak os komunikuje sie ze swapem?
    jak byl plik /swap, to jest read/write, ale teraz? Chyba musi /dev/sda2 gdzies zamountowac zeby wiedziec jak z tym gadac. A moze kernel robi to po cichu?

    Anyway, po swiezej instalce nie mam pliku /swap, ciekawi mnie czemu.

  2. #2
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    Co mowi 'mount' albo plik /etc/fstab?
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

  3. #3
    Zarejestrowany
    Aug 2009
    Postów
    408

    Domyślnie

    no wlasnie nic.
    fstab zmienialem 100 razy, wiec tez niewiele.


    mount:
    /dev/sda1 on / type ext4 (rw,relatime,errors=remount-ro)
    tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
    varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
    udev on /dev type tmpfs (rw,mode=0755)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
    fusectl on /sys/fs/fuse/connections type fusectl (rw)
    lrm on /lib/modules/2.6.28-15-generic/volatile type tmpfs (rw,mode=755)
    securityfs on /sys/kernel/security type securityfs (rw)
    binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
    gvfs-fuse-daemon on /home/a/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=a)

    i jak widac sda2 nigdzie nima

  4. #4
    Zarejestrowany
    Sep 2009
    Skąd
    Z Nienacka
    Postów
    396

    Domyślnie

    Spróbuj ręcznie dopisać do /etc/fstab

    Kod:
    /dev/sda2   none   swap   sw   0   0
    i reboot...

    Jak nie pomoże to podaj wynik komendy

    Kod:
    fdisk -l
    Jak nic niema to jeśli się nie mylę jest taka komenda jak

    Kod:
    mkswap
    Ale specem z linuksa to ja nie jestem...

    pozdrawiam

  5. #5
    Zarejestrowany
    Aug 2009
    Postów
    408

    Domyślnie

    akurat w fstab mam dokladnie to


    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 9483 76172166 83 Linux
    /dev/sda2 9484 9729 1975995 82 Linux swap / Solaris

  6. #6
    Zarejestrowany
    Sep 2009
    Skąd
    Z Nienacka
    Postów
    396

    Domyślnie

    To zrób sobie kopię zapasową fstab i wklep to co Ci podałem...

    Kod:
    /dev/sda2   none   swap   sw   0   0
    Oczywiście na własne ryzyko...

    Według mnie masz błędne wpisy w fstab...ale może wypowie się ktoś bardziej biegły w linuksie...

    Jak Ci się spieszy to spróbuj tego co Ci podałem

    pozdrawiam

    EDIT

    Ehhh... nie zauważyłem, że to wynik fdisk'a... Mój post już nie aktualny... TQM ma rację...
    Ostatnio edytowane przez lojciecdyrektor : 10-07-2009 - 19:09 Powód: Problemy ze wzrokiem ;-)

  7. #7
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    @rax666 podales co pokazuje fdisk -l
    zawartosc /etc/fstab jasno pokazuje ze masz podmontowany swap, czasami zamiast /dev/sdaN mozesz miec dlugasny UUID ale nie pamietam jak to sprawdzic ktora to jest partycja ;-)

    Na jedno wychodzi, jak /etc/fstab mowi ze masz swap to na pewno masz swap. Widzisz ile ta partycja zajmuje wiec 'free -m' pokaze ile masz swap'u dostepne w MB i bedziesz wiedzial czy partycja zamontowana czy nie.
    Swap emulowany na plikach stosuje sie w ostatecznosci i nie jest to zalecane rozwiazanie, bo jest sporo wolniejsze od dedykowanej partycji.
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

  8. #8
    Zarejestrowany
    Aug 2009
    Postów
    408

    Domyślnie

    aha, ale ciekawi mnie dlaczego teraz jest inaczej, bez pliku.
    linuxa instalowalem nie pierwszy raz, ale tylko teraz jest bez mounta.

    free -m:
    total used free shared buffers cached
    Mem: 988 871 116 0 31 477
    -/+ buffers/cache: 362 625
    Swap: 1929 23 1906


    a fstab nic nie musi mi pokazywac bo wpis moze byc bledny, to tylko config file.
    fdisk -l pokazuje mi ze partycja jest...

  9. #9
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    Mount nie pokazuje bo zmienilo sie sporo w samym systemie - kiedys system nie uzywal UUID tylko wszytko bazowalo na nazwach urzadzen... u mnie tez nie pokazuje ze swap jest podmontowany a jednak jest, co potwierdza 'free' tak samo jak u Ciebie, wiec jest ok jak dla mnie
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

  10. #10
    Zarejestrowany
    Aug 2009
    Postów
    408

    Domyślnie

    taa swiezo po instalacji tez mialem uuid ale zamienilem na normalne /dev/.
    po cholere to uuid?
    /dev/sda1 to id kabelka ktory jest podpiety, a uuid? co to za cholerstwo. wygloda losowo, a to zly znak - losowo = latwo o umyslna lub nie kolizje.

Strona 1 z 2 12 OstatniOstatni

Zasady Postowania

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  
Subskrybuj