Pokaż wyniki 1 do 9 z 9

Temat: Budowa domowej sieci - problemy

  1. #1
    Zarejestrowany
    May 2008
    Skąd
    uk
    Postów
    17

    Unhappy Budowa domowej sieci - problemy

    Otóż, tak wygląda plik interfaces:

    Kod:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    allow-hotplug eth0
    iface eth0 inet dhcp
    dns-nameservers 194.204.159.1 194.204.152.34
    
    # Secondary network interface
    allow-hotplug eth1
    iface eth1 inet static
            address 10.0.0.1
            netmask 255.255.255.0
            broadcast 10.0.0.255
    Łączę sie tak:

    internet--bramka Voip--serwer(debian-eth0 i eth1)--switch--komputery LAN

    Problem zaczyna sie w momencie jak włączam kabel ethernetowy do etch1, bowiem w konsoli podczas restartu i uruchamiania systemu pokazuje sie komunikat po kilkadziesiąt razy:

    Kod:
    eth1: link up, 10Mbps , half-duplex, lpa 0x0000
    eth1: link down
    i tak w kółko, aż po 2 min pokazywania tego komunikatu włączy się system, lecz nie rozdziela łącza na komputery LAN.

    MASQUERADE robiłem tak:
    Kod:
    iptables -t nat -A POSTROUTING -s 10.0.0.0/24 -j MASQUERADE
    iptables -A FORWARD -s 10.0.0.0/24 -j ACCEPT
    Proszę o pomoc,
    pozdrawiam

  2. #2
    Zarejestrowany
    Nov 2006
    Skąd
    Polska/Poland
    Postów
    1,191

    Domyślnie

    Masz włączony IP forwarding..?
    Pokaż jajku, przez, który interfejs ma wychodzić MASQ.

    Imho skoro masz statyczne IP użyj raczej statycznego NAT...
    ***********
    * markossx *
    ***********

  3. #3
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    Nie dziala dlatego ze MASQUERADE masz zle ustawione - brakuje Ci jednego parametru i przez to maskarada odbywa sie na wszystkich interfejsach, zgodnie z regula ktora podales.

    Skad niby system ma wiedziec na ktorym laczu ma odbywac sie cala akcja? Pomysl sam co bedzie jesli MASQUERADE bedzie odbywac sie w obie strony... dokladnie - rozrysuj sobie na papierze to bedzie jasniej


    BTW. Podczas restartu systemu zmiana interfejsow up/down to w miare normalne ale pare razy a nie parenascie. Jesli parenascie to sprawdz kable i swich/karte bo masz cos nie tak ze sprzetem.
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

  4. #4
    Zarejestrowany
    May 2008
    Skąd
    uk
    Postów
    17

    Domyślnie

    Cytat Napisał markossx Zobacz post
    Masz włączony IP forwarding..?
    Pokaż jajku, przez, który interfejs ma wychodzić MASQ.

    Imho skoro masz statyczne IP użyj raczej statycznego NAT...
    O to Ci chodziło?:

    Kod:
    iptables -t nat -A POSTROUTING -s 10.0.0.0/24 -j MASQUERADE
    iptables -A FORWARD -s 10.0.0.0/24 -j ACCEPT
    Na eth0 dostaje dhcp, a na eth1 wpisalem recznie/statycznie - dobrze?

  5. #5
    Zarejestrowany
    May 2008
    Skąd
    uk
    Postów
    17

    Domyślnie

    Cytat Napisał TQM Zobacz post
    Nie dziala dlatego ze MASQUERADE masz zle ustawione - brakuje Ci jednego parametru i przez to maskarada odbywa sie na wszystkich interfejsach, zgodnie z regula ktora podales.

    Skad niby system ma wiedziec na ktorym laczu ma odbywac sie cala akcja? Pomysl sam co bedzie jesli MASQUERADE bedzie odbywac sie w obie strony... dokladnie - rozrysuj sobie na papierze to bedzie jasniej


    BTW. Podczas restartu systemu zmiana interfejsow up/down to w miare normalne ale pare razy a nie parenascie. Jesli parenascie to sprawdz kable i swich/karte bo masz cos nie tak ze sprzetem.
    Problem okazał sie z kablem...

    pomogł plik umieszczony w init.d jako firewall:
    iptables -t nat -A POSTROUTING -s 10.0.0.0/24 -j MASQUERADE
    iptables -A FORWARD -s 10.0.0.0/24 -j ACCEPT
    Ostatnio edytowane przez judin : 01-20-2009 - 11:45

  6. #6
    Zarejestrowany
    Nov 2006
    Skąd
    Polska/Poland
    Postów
    1,191

    Domyślnie

    Chodziło o wartość w pliku:
    Kod:
    /proc/sys/net/ipv4/ip_forward
    Skoro działa masz włączone czyli 1
    Odnośnie mowy o statycznym IP źle spojrzałem na Twoje interfejsy - MASQ jest potrzebne bo maskujesz do dynamicznie przydzielanego IP, sorki za zamieszanie.

    Kod:
    iptables -t nat -A POSTROUTING -s 10.0.0.0/24 -j MASQUERADE
    Dodaj jeszcze interfejs wychodzący dla NAT i będzie książkowo:
    Kod:
    iptables -t nat -A POSTROUTING -s 10.0.0.0/24 -o eth0 -j MASQUERADE
    Dokładne opisywanie zachowań filtra oszczędza zasoby maszyny
    ***********
    * markossx *
    ***********

  7. #7
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    ... a jak nie podasz -o interfes to nie raz sie zdziwisz, ze masz jakies dziwne pakiety na sieci
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

  8. #8
    Zarejestrowany
    Nov 2006
    Skąd
    Polska/Poland
    Postów
    1,191

    Domyślnie

    Bogony drogi Sherlock'u
    ***********
    * markossx *
    ***********

  9. #9
    Zarejestrowany
    May 2008
    Skąd
    uk
    Postów
    17

    Domyślnie

    Dziekuje panowie - zastosuje sie!!

Podobne wątki

  1. 2 problemy (pomocy )
    By men01 in forum GSM/GPRS/EDGE/UMTS
    Odpowiedzi: 5
    Autor: 02-26-2009, 23:29
  2. Jak podzielic sygnal w domowej sieci bezprzewodowej
    By sultan75 in forum Inne metody
    Odpowiedzi: 8
    Autor: 06-18-2008, 10:37
  3. BTS domowej roboty.. 400zl
    By `^` in forum GSM/GPRS/EDGE/UMTS
    Odpowiedzi: 21
    Autor: 06-02-2008, 19:14
  4. iptables na ruterze w sieci domowej
    By ds1978 in forum Security
    Odpowiedzi: 6
    Autor: 03-07-2008, 20:59
  5. Budowa HACKME nowej generacji
    By sapheal in forum Pomysły/Sugestie
    Odpowiedzi: 0
    Autor: 03-29-2007, 09:36

Zasady Postowania

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  
Subskrybuj