Pokaż wyniki 1 do 10 z 10

Temat: znaczki np. ł

  1. #1
    Zarejestrowany
    Feb 2008
    Postów
    22

    Domyślnie znaczki np. ł

    witam robie strone programem w którym robi się obrazkowo. Gdy piszę słowo z zawartością ł jest dobrze . ale gdy strone opublikuje ten ł zmienia znak na jakiś dźiwny. pomocy .Pomocy !!!!!!!!!!!!!!

  2. #2
    Avatar hedVB
    hedVB jest offline AI
    Zarejestrowany
    Nov 2007
    Postów
    874

    Domyślnie

    Najprawdopodobniej musisz ustawić polskie kodowanie znaków (ISO-8859-2 ) w sekcji meta oczywiście
    www.lingubot.pl - projekt sztucznej inteligencji.

  3. #3
    Avatar gogulas
    gogulas jest offline killboy powerhead
    Zarejestrowany
    Sep 2007
    Skąd
    Tu
    Postów
    1,236

    Domyślnie

    Przy ISO-8859-2 miewam cyrki, na IE dziala, na Operze dziala, a na Mozilli krzaki, za to UTF-8 jest zawsze fine.
    http://gogulas.yoyo.pl/h.gif

  4. #4
    Avatar hedVB
    hedVB jest offline AI
    Zarejestrowany
    Nov 2007
    Postów
    874

    Domyślnie

    Przy ISO-8859-2 na IE działa, Na Mozilli działa (na operze nie wiem), przy UTF-8 - kompletnie nie rozpoznawane są polskie ogonki, zresztą nie ma się co dziwić ....
    www.lingubot.pl - projekt sztucznej inteligencji.

  5. #5
    Avatar gogulas
    gogulas jest offline killboy powerhead
    Zarejestrowany
    Sep 2007
    Skąd
    Tu
    Postów
    1,236

    Domyślnie

    Cytat Napisał hedVB Zobacz post
    przy UTF-8[/B] - kompletnie nie rozpoznawane są polskie ogonki, zresztą nie ma się co dziwić ....
    To bardzo dziwne, poniewaz wszystkie moje weby chodza na UTF i polskie znaki sa rozpoznawane bez najmniejszego problemu, trzeba jeszcze tresc samego dokumentu zapisac w takim standardzie :P

    iso na ie tak, na operze tak, a na ff nie, tak jak napisalem wyzej, nie wiem co moglo byc przyczyna..
    Ostatnio edytowane przez gogulas : 03-20-2008 - 16:39
    http://gogulas.yoyo.pl/h.gif

  6. #6
    Avatar hedVB
    hedVB jest offline AI
    Zarejestrowany
    Nov 2007
    Postów
    874

    Domyślnie

    iso na ie tak, na operze tak, a na ff nie, tak jak napisalem wyzej, nie wiem co moglo byc przyczyna..
    To ciekawe bo jakoś mi na FF bez problemu wyświetla ogonki
    www.lingubot.pl - projekt sztucznej inteligencji.

  7. #7
    Avatar gogulas
    gogulas jest offline killboy powerhead
    Zarejestrowany
    Sep 2007
    Skąd
    Tu
    Postów
    1,236

    Domyślnie

    Cytat Napisał hedVB Zobacz post
    To ciekawe bo jakoś mi na FF bez problemu wyświetla ogonki
    No ja wiem ze z reguly tak jest, ale robilem ostatnio strone i iso dzialalo na wszystkim poza FF,
    http://gogulas.yoyo.pl/h.gif

  8. #8
    Avatar hedVB
    hedVB jest offline AI
    Zarejestrowany
    Nov 2007
    Postów
    874

    Domyślnie

    http://gajdaw.pl/varia/polskie-ogonki-na-www/print.html

    Rozwiązanie jakichkolwiek wątpliwości / problemów z kodowanie polskich znaków Sam jestem w trakcje czytania :P
    www.lingubot.pl - projekt sztucznej inteligencji.

  9. #9
    Zarejestrowany
    Jan 2007
    Skąd
    somewhere in time
    Postów
    510

    Domyślnie

    nie wiem czy to jest prawda ale podobno jak piszesz notatnikiem strony to nawet jak ustawisz na te iso-8859-2 to i tak to naprawde nie bedzie w tym formacie zapisane///na notatniku podobno dziala tylko windows-1250 ....tak gdzies mi sie obilo o uszy....i wtedy trzeba jak jakims programem do konwersji pojechać np gżegżółka xp .

  10. #10
    Zarejestrowany
    Jun 2006
    Skąd
    rand(.eu)
    Postów
    8,748

    Domyślnie

    O to samo pytales w dziale Windows... i dalej leniu smierdzacy nie raczysz zajrzec do byle kursu HTML i przeczytac o metodach kodowania znakow!

    ZAMYKAM!

    Windows uzywa windows-1250 (notatnik i inne apliacje windowsowe). Oficjalny standard dla Polski to ISO-8859-2, mozna tez stosowac UTF-8. Teraz poskladaj do kupy narzedzie, znaczki i odpowiedni naglowek i bedzie dzialac.

    @all - jesli przegladarka nie rozpoznaje kodowania to sprawdzcie naglowki odsylane przez serwer - niektore serwery wysylaja swoj content-encoding i tam daja default charset - to wtedy rozwala robote.
    ctrl-alt-del.cc - soft reset site for IT admins and other staff :-)

Zasady Postowania

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  
Subskrybuj