Pokaż wyniki 1 do 6 z 6

Temat: [BATCH][C++][TELNET] Problemik

  1. #1
    Zarejestrowany
    Aug 2007
    Postów
    10

    Domyślnie [BATCH][C++][TELNET] Problemik

    A więc:
    Z powodu ferii zacząłem się nudzić i wymyśliłem sobie że stworze program wysyłający maile.
    Kod:
    telnet poczta.o2.pl
    AUTH LOGIN
    <login>
    <password>
    [i cos tam dalej]
    a więc teraz jak to umieścić w c++
    Ponieważ gdy pisze
    Kod:
    Kod:
    System("telnet poczta.o2.pl");
    Nie wiem jak obsłużyć konsolke telneta.
    Dowiedziałem sie o popen ale mamy błąd:
    Kod:
     error C3861: 'popen': identifier not found
    Może wy pomożecie!

  2. #2
    Avatar rafal44
    rafal44 jest offline logout
    Zarejestrowany
    Dec 2007
    Postów
    291

    Domyślnie

    Zainteresuj się socketami, słóżą one do komunikacji sieciowej. Tutaj możesz znaleźć potrzebne informacje.
    "a imię jego będzie czterdzieści i cztery"
    A. Mickiewicz Dziady cz. III

  3. #3
    Avatar Michal_sh
    Michal_sh jest offline (s)aint
    Zarejestrowany
    Apr 2007
    Postów
    688

    Domyślnie

    A może byś tak użył odpowiedniego portu do protokołu co?

  4. #4
    Zarejestrowany
    Aug 2007
    Postów
    10

    Domyślnie

    @2x up
    Interesuje mnie napisanie tego przez telnet
    @Michal~
    port normalnie wpisuje tu sie tylko pomylilem

  5. #5
    Avatar Michal_sh
    Michal_sh jest offline (s)aint
    Zarejestrowany
    Apr 2007
    Postów
    688

    Domyślnie

    Nie mam pojęcia jak to zrobić , sam kiedyś próbowałem napisać taki program i właśnie na poleceniach przekazywanych do telnetu się zatrzymałem. Rozwiązanie mnie też zainteresuje. Myślałem ze opracowałeś dalszą część kodu , a błąd ci wywala z powodu małego przeoczenia. Nie jestem zaawansowanym koderem C ,ale myślę ,że na forum znajdzie się jakiś pr0
    Ostatnio edytowane przez Michal_sh : 02-23-2009 - 21:02

  6. #6
    Zarejestrowany
    Aug 2007
    Postów
    10

    Domyślnie

    Michał jak byś wyczaił ten błąd gdzie on jest lub co oznacza myślę że nie było by problemu z tym programikiem ;-)
    @EDIT:Popen działa teraz mam problem jak wpisać do potoku tekst;/
    Ostatnio edytowane przez Tinek : 02-23-2009 - 23:24

Podobne wątki

  1. Nie umiem uzyc keyloggera [bylo: Problemik]
    By Pomocnik in forum /dev/null
    Odpowiedzi: 4
    Autor: 09-22-2007, 17:48
  2. batch
    By w4j in forum Inne języki
    Odpowiedzi: 19
    Autor: 03-22-2007, 12:25
  3. mini wirus batch
    By Sardihan in forum Hacking
    Odpowiedzi: 7
    Autor: 01-05-2007, 17:37
  4. Mam maly problemik/pytanko
    By XoSiDoX in forum Kryptografia
    Odpowiedzi: 2
    Autor: 10-19-2006, 22:36

Zasady Postowania

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •  
Subskrybuj