Łatanie WordPressa

Developerzy systemu blogowego WordPress opublikowali wersję 2.3.3, w której załatali dziurę, pozwalającą obcym osobom na edytowanie cudzego bloga. Umożliwiała to błędna implementacja XML-RPC.

To już kolejna luka w XML-RPC, z którą musieli poradzić sobie twórcy WordPressa. W wersji 2.3.3 poprawiono też kilka błędów mniejszej wagi.

Osoby, które chcą się zabezpieczyć przed luką w XML-RPC nie muszą instalować pełnej wersji 2.3.3. Wystarczy, że pobiorą i zainstalują poprawiony skrypt xmlrpc.php.

Developerzy WordPressa informują, że ciągle nie załatali dziury we wtyczce WP-Forum. Zalecają, by do czasu pojawienia się poprawek zrezygnować z jej używania.

Źródło: ArcaBit

Realizacja: SIPLEX Studio