Krytyczna luka komunikatorze ICQ

Specjaliści z firm Secunia i FrSIRT informują, że odpowiednio spreparowane wiadomości, mogą doprowadzić do awarii komunikatora ICQ 6 u innych użytkowników. Przyczyną problemu jest błąd w filtrowaniu łańcucha formatującego podczas przetwarzania wiadomości HTML zawierających specyfikator w rodzaju %020000000p.

Błąd ten może zostać wykorzystany do wstrzyknięcia i wykonania kodu. Nie poinformowano, czy cyberprzestępcy już korzystają ze wspomnianej dziury.

Narażony na występowanie błędu jest klient ICQ w wersji 6 Build 6043. Bardzo prawdopodobne, że zawierają ją też i inne edycje programu.

Na razie nie istnieje łata chroniąca przed atakiem. Można się przed nim częściowo bronić nieakceptując żadnych informacji od nieznanych osób i natychmiast wyrzucając je do kosza. Z listy znajomych należy skasować też przypadkowe osoby.

Źródło: ArcaBit

Realizacja: SIPLEX Studio