Atak na linuksowe drukarki

Secunia odkryła błąd przepełnienia bufora w CUPS - systemie obsługi urządzeń drukujących dla systemów uniksowych. Dziura została znaleziona w wersji 1.3.3. Prawdopodobnie występuje też we wszystkich wcześniejszych edycjach CUPS.

Dzięki wspomnianej luce cyberprzestępca może przejąć kontrolę nad serwerem. Na szczęście ryzyko ataku ograniczone jest faktem, iż CUPS jest zwykle dostępny tylko z sieci lokalnej. Błąd przepełnienia bufora dotyczy funkcji ippReadIO w pliku cups/ipp.c i może zostać wywołany za pomocą odpowiednio spreparowanych pakietów IPP.

Według Secunii wystarczy, by atakujący wysłał odpowiednio spreparowane tagi textWithLanguage lub nameWithLanguage.

Opublikowano już wersję 1.3.4 CUPS, w której naprawiono powyższy błąd oraz kilka innych niedociągnięć niezwiązanych z systemem. W najbliższym czasie odpowiednie wersje CUPS-a powinni przygotować twórcy systemów Linux i Unix. Z CUPS korzysta również system Mac OS X.

Źródło: ArcaBit

Realizacja: SIPLEX Studio